Follow

Velocify Browser Compatibility

Browsers

The browsers compatible with Velocify solutions are:

  • Internet Explorer 10.0 or above 
  • Latest version of Mozilla Firefox (Mozilla Firefox updates automatically to the most recent version)
  • Latest version of Google Chrome (Google Chrome updates automatically to the most recent version)

Using a browser not in this list may result in unexpected behaviors that keep users from realizing the full potential of Velocify solutions.

Velocify Support may not be able to diagnose issues that occur when using incompatible browsers. 

For the supported browsers above, please ensure that your browser is able to accept cookies and that Javascript is enabled.

Note that while we do not formally test or support our products on Mac OS, we have not seen issues with LeadManager using the Safari Browser.

 

 

 

 

 

 

 

 

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments

Powered by Zendesk