Dear Valued Velocify Client,

 

 

On Tuesday, October 14th, Google announced the discovery of an SSL vulnerability present in an older variant of SSL protocol, version 3 (SSLv3) that is currently utilized by Velocify. To remedy this, Velocify is immediately taking steps to mitigate against this recently disclosed vulnerability by disabling all usage of SSLv3 throughout the Velocify product line. 

These new security measures will be activated within LeadManager production environments on Tuesday, November 4th.

Will I see any changes in LeadManager as a result of the changes to defend against POODLE?

For LeadManager users who utilize the most recent version of Chrome, Firefox, or Internet Explorer 7.0 or later, there should be no noticeable change in LeadManager operability.  

Users who are currently using legacy versions of Internet Explorer that precede version 7.0 (notably IE 6.0) will not be able to log in to LeadManager. 
 
Do I need to do anything?

Only if you or members of your organization still utilize legacy versions of Internet Explorer that precede IE 7.0.  Users with IE versions that precede 7.0 will not be able to log in to LeadManager and will therefore need to take steps to upgrade their browser.

As stated previously, Velocify does not support versions of Internet Explorer that precede 7.0 and recommends that any users who are using a legacy version of Internet Explorer upgrade to a current version of that browser.

If you have further questions or require assistance, please contact us at support@velocify.com or through your Account Manager.

Thank you,

 

The Velocify Team